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OFFICIAL LICENSE AGREEMENT 
Liaison Software Corporation 

 
The Software or Firmware, referred to as “Program”, is licensed not sold. Liaison 
Software Corporation, or the applicable Liaison Software Country organization, 
grants you a license for the Program only in the country for which it was 
acquired. You obtain no rights other than those granted you under this license. 
 
The term “Program” means the original and all whole or partial copies of it, 
including modified copies or portions merged into other programs. Liaison 
Software Corporation retains title to the Program. Liaison Software Corporation 
owns, or has licensed from the owner, copyrights in the Program. 
 
You are responsible for the selection of the Program and for the installation of, 
use of, and results obtained from the Program. 
 
1. License 
Under this license, you may: 1) Use the Program on only one machine at any one 
time for the Single‐user version of the program and on only one server at any 
one time for the multi‐user version of the Program. When data and programs are 
on different servers, a multi‐server or WAN (Wide Area Network) license is 
required. 2) Copy the Program for backup. 3) Transfer possession of the 
Program to another party. 
 
If you transfer the Program, you must transfer a copy of this license, all other 
documentation, and at least one complete, unaltered copy of the Program to the 
other party. You must, at the same time, either transfer all of your other copies 
of the Program to the other party or destroy them. Your license is then 
terminated. The other party agrees to these terms and conditions by its first use 
of the Program. 
 
You may not: 1) Use, copy, modify, merge, or transfer copies of the program 
except as provided in this license. 2) Reverse assemble or reverse compile the 
Program. 3) Sublicense, rent, lease, or assign the Program. 
 
2. Limited Warranty 
The Programs are not warranted and are licensed on an “AS IS” basis by Liaison 
Software Corporation. All Programs have a 30 day limited warranty on their 
media, which commences from the date of purchase. 
 
THESE WARRANTIES ARE IN LIEU OF ALL OTHER WARRANTIES (OR 
CONDITIONS), EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, 
THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A 
PARTICULAR PURPOSE. 
 
SOME JURISIDICTIONS DO NOT ALLOW THE EXCLUSIONS OF IMPLIED 
WARRANTIES, SO THE ABOVE EXCLUSION MAY NOT APPLY TO YOU. 
 
3. Limitations Of Remedies 
Liaison Software Corporation entire liability and your exclusive remedy shall be: 
1) The replacement of any diskette not meeting the “Limited Warranty” and 
which is returned to Liaison Software Corporation along with your original 
purchase receipt. 
 
If Liaison Software Corporation is unable to deliver a replacement diskette, 
which is free from defects in materials or workmanship, you may terminate this 
Agreement by returning the programs, documentation, hardware and any other 
materials provided, within 90 days of purchase, and your money will be 
refunded. 
 

IN NO EVENT WILL LIAISON SOFTWARE CORPORATION BE LIABLE TO YOU 
FOR ANY DAMAGES, INCLUDING ANY LOST PROFITS, LOST SAVINGS, OR OTHER 
INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OR 
INABILITY TO USE LIAISON SOFTWARE CORPORATION PROGRAMS OR 
HARDWARE EVEN IF LIAISON SOFTWARE CORPORATION HAS BEEN ADVISED 
OF THE POSSIBILITY OF SUCH DAMAGES OR FOR ANY CLAIM BY ANY OTHER 
PARTY. 
 
SOME STATES DO NOT ALLOW THE LIMITATION OR EXCLUSION OF LIABILITY 
FOR INCIDENTAL OR CONSEQUENTIAL DAMAGES, SO THE ABOVE LIMITATION 
OR EXCLUSION MAY NOT APPLY TO YOU. 
 
4. General Provisions 
You may terminate your license at any time. Liaison Software Corporation may 
terminate your license if you fail to comply with the terms and conditions of this 
license.  In either event, you must destroy all your copies of the Program. You 
may not sublicense, assign or transfer this license, programs, or the program 
documentation except as expressly provided for in this Agreement. Any attempt 
otherwise to sublicense, assign or transfer any of the rights, duties, or 
obligations hereunder is null and void.  You are responsible for payment of any 
taxes, resulting from this license. Neither party may bring an action, regardless 
of form, more than two years after the cause of action arose. If you acquired the 
Program in the United States, the laws of the state of California govern this 
license. If you acquired the Program in Canada, the laws of the Province of 
Ontario govern this license. Otherwise, this license is governed by the laws of the 
country in which you acquired the Program. 
 
5. Intellectual Property Rights 
a) RESELLER recognizes LIAISON's and/or the relevant manufacturer(s) right, 
title and interest in and to the rights to patents, design, utility models, software 
architecture and coding methodology, trademarks, trade names, know‐how, 
trade secrets, copyright, photography rights and other industrial and intellectual 
property rights, hereafter collectively referred to as "Intellectual Property 
Rights", relating to the Products. b) Specifically, all right, title and interest in and 
to the Intellectual Property Rights relating to the Products shall at all times 
remain the property of LIAISON and/or the manufacturer(s) and RESELLER 
shall not use any Intellectual Property Rights in any manner except as permitted 
in this Agreement or by prior written authorization of LIAISON and/or the 
manufacturer(s). c) RESELLER shall not remove or alter any Intellectual 
Property Rights notice associated with the Products without the express written 
permission of LIAISON and/or the manufacturer(s). d) RESELLER agrees that it 
will not de‐compile, reverse engineer, or otherwise in any manner attempt to 
derive or have derived the source code for the Products, except to the extent 
allowed under applicable law. e) RESELLER agrees that it will not use the 
provided Not For Resale products to develop a product, which may compete 
with Liaison Software Corporation or the products of Liaison Software 
Corporation. f) RESELLER agrees not to lend, borrow, resell, or reassign the 
provided products to any 3rd Party who may develop, produce or resell a 
competing product or who may compete with Liaison Software Corporation. 
 

Should you have any questions about this 
Agreement, you may contact Liaison Software 

Corporation by writing to 2021 E. 4th Street, Suite 
218, Santa Ana, CA 92705.
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Liaison Messenger® Support 
and Maintenance Agreement 
 
 Upon payment of the annual maintenance and support services fee, 
Liaison Software Corporation© doing business as Liaison, (“Liaison”) 
will provide the following maintenance and support services to the 
registered user (“you”) for Liaison Messenger® software (the 
“Software”) during the Term: 
 
MAINTENANCE AND SUPPORT BENEFITS.  All (a) updates for the 
installed and registered Software (including related documentation) 
commercially released by Liaison during the Term (updates consist of 
new releases of a particular software version which provide functional 
enhancements and error corrections which are indicated by a change 
in the numeric identifier in the digits to the right of the decimal such as 
from version .0 to version .0a). In addition, Liaison shall provide a 
discount on all version and product upgrades to the Software that are 
commercially released by Liaison during the Term (version upgrades 
consist of new releases with a higher version number such as from 2.x 
to 3.x.  
 
TELEPHONE AND FACSIMILE SUPPORT. Liaison shall provide 
unlimited telephone and facsimile support. The hours of support of 
operation are 7:00a.m. to 4:00 p.m. Pacific Standard Time, during 
normal business hours (Monday through Friday), excluding holidays. 
The registered user shall appoint up to two (2) individuals within its 
organization to serve as the primary contacts between Liaison and the 
registered user, and to receive support through the telephone support 
center. The registered user can increase the number of permissible 
contacts subject to payment to Liaison of additional fees. Phone 
support will be offered for the current release, plus one release back 
(e.g., releases 1.5 and 2.0).  
 
Telephone and facsimile support does not include customization to 
templates, custom templates or filters made by the registered user or 
consultant employed by the registered user. Any necessary support to 
templates, custom templates or filters is billable by Liaison at the 
current hourly rate per hour. At the discretion of Liaison Software 
Corporation, Liaison may require prepayment before modifications are 
completed. 
 
LIMITED WARRANTY. Liaison warrants that the support services will 
be performed in a professional workmanlike manner. EXCEPT FOR 
THE EXPRESS WARRANTY PROVIDED ABOVE, THE SUPPORT 
SERVICES ARE PROVIDED “AS IS” AND WITHOUT A WARRANTY OF 
ANY KIND, WHETHER EXPRESS, IMPLIED, STATUTORY OR 
OTHERWISE, AND LIAISON SPECIFICALLY DISCLAIMS ANY IMPLIED 
WARRANTY, TERM OR CONDITION OF MERCHANTABILITY, NON‐
INFRINGEMENT AND FITNESS FOR A PARTICULAR PURPOSE. THIS 
LIMITED WARRANTY GIVES YOU SPECIFIC LEGAL RIGHTS AND YOU 
MAY HAVE OTHER RIGHTS WHICH VARY FROM STATE TO STATE. 
 
LIMITATION OF LIABILITY. Liaison’s entire liability to you or any other 
party for any loss or damage resulting from any claims, demands or 
actions arising out of this Agreement shall not exceed the annual 

maintenance and support fee paid to Liaison for the software, net of 
dealer or distributor margins, notwithstanding any failure of essential 
purpose of any limited remedy. 
 
NO LIABILITY FOR CONSEQUENTIAL DAMAGES. IN NO EVENT SHALL 
LIAISON OR ITS SUPPLIERS BE LIABLE FOR ANY INDIRECT, 
INCIDENTIAL, CONSEQUENTIALS, SPECIAL OR EXEMPLARY DAMAGES 
WHATSOEVER (INCLUDING, WITHOUT LIMITATION, DAMAGES FOR 
LOSS OF BUSINESS PROFITS, BUSINESS INTERRUPTION, LOSS OF 
BUSINESS INFORMATION, OR OTHER PECUNIARY LOSS) ARISING OUT 
OF THE USE OR INABILITY TO USE THE SOFTWARE OR THE 
PERFORMANCE OR FAILURE TO PERFORM SUPPORT SERVICES, EVEN 
IF LIAISON OR ITS SUPPLIERS HAVE BEEN ADVISED OF THE 
POSSIBILITY OF SUCH DAMAGES AND NOTWITHSTANDING ANY 
FAILURE OF ESSENTIAL PURPOSE OF ANY LIMITED REMEDY. 
BECAUSE SOME STATES DO NOT ALLOW THE EXCLUSION OR 
LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTIAL 
DAMAGES, THE ABOVE LIMITATION MAY NOT APPLY TO YOU. 
 
TERM. Upon payment of the annual maintenance and support services 
fee, this document certifies that the registered user identified on the 
accompanying invoice is entitled to receive the maintenance and 
support services described herein for the one (1) year period specified 
on the invoice (the “Term”). The Term may be renewed for successive 
one (1) year periods. The registered user will be invoiced for annual 
renewals, and the Term will be appropriately renewed, unless Liaison 
receives written notification canceling the subscription 60 days prior 
to the expiration date of the Term. If the registered user does not pay 
such invoice by the expiration of the then‐current Term, the registered 
user shall not be entitled to receive the maintenance described herein, 
and the Term will not be renewed or extended. 
 
CONDITIONS. If you allow your maintenance and support plan to 
expire and desire to resume maintenance and support, you must pay a 
reinstatement fee for lapsed coverage of software maintenance and 
support in accordance with Liaison’s then current maintenance and 
support program. If you cancel your subscription to maintenance and 
support at any time during the Term of your subscription period, no 
refund, pro‐rated or otherwise, will be given. This agreement is for one 
plan, per registered user, for all registered modules.  If the use of a 
specific licensed and registered module is discontinued, a letter must 
be sent on a company letterhead prior to the commencement of the 
next subscription period (signed by an officer of the company) 
indicating that the company is no longer using the module.  
 
LAW. If you acquired the Software in the United States, this Agreement 
is governed by the laws of the State of California.  If you acquired this 
product in Australia, New Zealand, Canada, Hong Kong, Singapore or 
the United Kingdom, this agreement is governed by the laws of New 
South Wales, New Zealand, the province of Ontario, Hong Kong, 
Singapore or England, respectively. 
 

Should you have any questions about this 
Agreement, you may contact Liaison 

Software Corporation by writing to 2021 E. 
4th Street, Suite 218, Santa Ana, CA 92705
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Support phone number: (714) 543-9877 x208 

Support e-mail: support@liaisonsc.com 

Website: www.liaisonsc.com 
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PRINTING FORMS WITH CLIENT 

 

SAVING SELECTION CRITERIA 

You can save common criteria in Views or Saved Parameters Listings. 
This way you do not have to reenter the criteria each time you want to 

print a select group of 
orders or invoice. 

 As you may have noticed, 
Messenger provides many 
new and different ways to 
select and print orders and 
invoices. 

 Use the Lookup, Save, and 
Clear buttons next to the 
Views field on the form to 
Access, Save, and Create 
these View Listings of 
Saved Parameters.  
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SAGE PFW 

PRINTING PFW/BATCHMASTER DOCUMENTS 

During the early stages of implementing Liaison Messenger, you may wish to run parallel with the PFW 
print routines for forms. If this is the case, uncheck the Update Document's Status Code from the 
System Setup screen in Messenger Server. This will cause the respective Checkbox to be unchecked in 
Messenger Client by default as shown in the screen shot below. 

If you do wish to run parallel, print the forms in PFW first, do NOT post, and then print the same forms in 
Messenger as a Rerun. Once printed from Messenger, you should post as you normally have done in 
the past. 

Now, the following 
procedures assume 
that Liaison 
Messenger will be 
printing and driving 
the forms printing and 
parallel processing 
will no longer be 
done. 

So, when you decide 
to run Messenger 
live, make sure you 
have checked Update 
Document's Status 
Code in System 
Configuration or from 
the respective forms 
Printing window.  

This is the only way Messenger can update the print status codes, assign invoices numbers and post 
work orders and purchase orders. 

NEW FOR PFW 5.6 ­ IS THE HOLD FLAG. LIAISON MESSENGER DOES RECOGNIZE 
THIS FIELD AND WILL NOT PROCESS THIS OR CHANGE THE DOCUMENT'S STATUS.  
YOU MAY; HOWEVER, PRINT AND PREVIEW THE DOCUMENT USING THE LOCAL 

VIEWER AND LOCAL PRINT BUTTONS.  THIS IS NICE FOR DESK‐TOP CHECKING. 

PFW POSTING PROCEDURES 

PLEASE NOTE THAT THE ONLY FORMS THAT LIAISON MESSENGER CAN POST ARE 
SALES ORDERS AND PURCHASE ORDERS. AR INVOICES AND SO INVOICES MUST BE 

POSTED IN PFW AFTER MESSENGER PRINTS THE FORM.  
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Since Messenger updates the Status codes to show they’ve been printed, the Invoices do not actually 
print again, but they will be posted following PFW standard methods. Also, during Invoice processing, 
Liaison Messenger does assign the Invoice Numbers using the same procedures as PFW and 
BatchMaster. 

AR INVOICES AND CREDIT MEMOS 

From the Messenger 
Client, select Print 
AR Invoices/Credit 
Memos from the File 
menu. Select the 
applicable fields and 
choose Process 
when ready. When 
everything has 
printed and looks 
OK. Run the Invoice 
Print & Post routine 
in PFW. The forms 
will not print but they 
will be posted. 

Credit Memos will 
be printed within an 
Invoice run; 
however, the form will say Credit Memo instead of Invoice with <Credit Memo> printed across the top.  

This eliminates the multiple step process you need to print Credit memos should you require pre-printed 
Credit Memo forms. 

If the Update Platinum Status Code is NOT checked, Invoices Numbers will NOT be assigned to 
invoices or credit memos and therefore not print.  

SALES ORDER INVOICES, PACKING SLIPS, BILLS‐OF‐LADING, INTERNATIONAL INVOICES 

From the Messenger Client, select Print SO Invoices from the File menu. When everything has printed 
and looks OK. Run the Invoice Print & Post routine in PFW.  

The forms will not print but they will be posted. If the Update Platinum Status Code is NOT checked, 
Invoices Numbers will NOT be assigned to invoices and therefore not print on the Invoice. 

SALES ORDERS, BACK ORDERS, PICKING TICKETS, QUOTATIONS, AND ACKNOWLEDGEMENTS 

From Messenger Client select Print Sales Orders from the File menu. Choose the appropriate values 
and select Process.  

PURCHASE ORDERS AND ADJUSTED ORDERS 
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From Messenger Client, choose Print Purchase Orders from the File menu. When everything has 
printed and looks OK. This Procedure will Post the Purchase Orders when you print them. If; however, a 
down payment had been entered on this P.O., you will have to run the Post Purchase Orders option in 
order to post the financial transaction. 

SHIPPING DOCUMENTS, PACKING SLIPS, BILLS‐OF‐LADING, INTERNATIONAL INVOICES 

From Messenger Client, 
choose Print Shipping 
Documents from the File 
menu. 

By default, Messenger 
preloads one Bill of Lading 
and Packing Slip. Of course 
you can change any or all of 
this if you want.  

This process does not have 
a posting function. It will 
work on Sales Order and 
Sales Order Invoices 
regardless of their status or 
selection flag.  

To further enhance this feature, you can add International Invoices, or create UPS waybill templates and 
add them to the Properties. With some clever filtering you can automate your entire shipping process. 

A nice tip is to try printing Bill of Ladings on 3-part continuous NCR paper using a Dot-Matrix printer. 
Messenger will create the entire form, text, borders, etc… The NCR paper will allow signatures to 
“crush” through to the 2nd and 3rd copies. If you are using BatchMaster, make sure you select the correct 
Bill of Lading when setting up the Shipping Documents in Properties. There is one for pre-printed and 
one for blank paper (BatchMaster Bill of Ladings) as well-as generic layouts under the available 
templates listing. 

There is also an option for you to specify a specific Ply Number (referencing the Ply number in 
Messenger Properties) of the Form Type as well as the number of copies. This is handy if you wish to 
create a Shipping Labels ply, special document or anything your imagination and Liaison Messenger 
permits.  

REPRINTING (UNPOSTED) INVOICES 

If a problem has arisen with the latest print job and they have not been posted in PFW, you can rerun 
the jobs. You will be prompted for the Invoice or Order Number range. After which you may select 
Process, which will rerun the last print job. 

REPRINTING (POSTED) HISTORICAL DOCUMENTS  
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If the order or invoice has 
already been posted, 
Messenger Client’s Recreate 
may assist you in regenerating 
a form.  

The PC/user making the 
Recreate request will print or 
preview the reprinted form. 
Messenger Server will service 
all New and Rerun print jobs. 
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DYNAMICS GP 

PRINTING DYNAMICS GP DOCUMENTS 

Make sure you have checked Update 
Times Printed Value in System 
Configuration or from the respective 
Messenger Client window.  

This is the only way Messenger can 
update any Status Codes and/or 
increment the Times Printed fields. 

AR INVOICES AND CREDIT MEMOS 

From the Messenger Client, select Print 
AR Invoices/Credit Memos from the File 
menu. Select Unprinted Unposted 
Documents from the drop-list box and 
then the applicable fields and choose 
Process when ready. 

Returns or Credit Memos will be printed within an Invoice run; however, the form will say Credit Memo 
instead of Invoice with <Credit Memo> printed across the top. This eliminates the multiple step process 
you need to print Credit memos should you require pre-printed Credit Memo forms.  

SOP INVOICES  

From the Messenger Client, 
select Print SO 
Invoices/Shippers from the 
File menu. Select the 
Process Unprinted Docs 
from the drop-list box, enter 
any other criteria in the 
applicable fields and choose 
Process when ready. 

SOP SALES ORDERS 

From Messenger Client 
select Print Sales Orders 
from the File menu and 
follow the instructions for the 
SOP Invoices. 

POP PURCHASE ORDERS  

From Messenger Client, choose Print Purchase Orders from the File menu follow the instructions for the 
SOP Invoices. 
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REPRINTING (POSTED) HISTORICAL GP DOCUMENTS 

If a problem has arisen with the latest print job and the documents have not yet been posted, you can 
rerun the print job(s) by simply select the desired process from the drop-list field in the upper left-hand 
section of the Print form and reselecting the criteria from the 1. Selections and 2. Extras tab(s). 

If the documents have been posted, they are considered Historical Documents and are recreated as 
such. Messenger Client’s Recreate 
capabilities may assist you in 
regenerating a form. The 2 options 
are  

1. Recreate Printed and 
Posted Documents  

2. Recreate Unprinted and 
Posted Documents.  

The selection of either of these 2 
options may dim out certain criteria 
selection fields; but, it may also 
enable the direct E-mail and Fax 
buttons for desktop control of re-
sending copies of these forms.  
More detailed information 
regarding this feature can be found 
later in this guide under: Desktop 
Faxing, E-mailing, and Local Printing. 

Also, there is an Archive tab on the form which can be used to retreive, view, print previously Archived 
documents. More detailed information regarding this feature can be found later in this guide under: 
Retrieving Archived forms. 

There is also an Archive Manger (found on the File menu)  where there is a tab for each form type. The 
Archive Manager reads the directory location from the Properties that were entered for that form.  This 
Archive Manager can be found Messenger Client and Messenger Server components. 

When launched, the Archive Manager displays all the files for the respective form in a scrolling list box.  
When a batch is selected (by double clicking), the respective file is displayed using the designated 
reader. In most cases this is the free Adobe Acrobat reader. 
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PRODUCING DYNAMICS GP EFT‐AP (ACCOUNTS PAYABLE) NOTICES 

To enable the EFT-AP 
module for Messenger, place 
a check in the respective 
EFT-AP  Enabled box on the 
EFT-AP/DD tab in System 
Configuration. 

Messenger EFT-AP or EFT-
DD will print, fax, or e-mail an 
EFT-AP Notice to the 
respective vendor or email 
and EFT-DD paystub to the  
employee whenever the 
Electronic Payment process is 
performed in Microsoft 
Dynamics GP. 

After you’ve enabled the 
module, you should specify a default printer, the desired polling interval and increment and the check 
the Update Notification Send Date fields. 

INCLUDE/EXCLUDE VENDORS 

The Vendor’s preference must be specified in Recipients Preferences in order for them to receive the 
EFT notice via email or fax. This can be done by selecting this option from the menu in Messenger 
Client, Messenger Server, or under the Messenger Properties Vendor tab. 

ESTABLISH THE EFT ROUTING RULES 

Once you’ve done the above steps, refer to the Chapter called Print, Fax, Email, & Routing to create 
your business rules for each EFT 
form template and ply.  

In System Configuration | EFT-
AP/DD tab the EFT module is 
enabled and configured. 

Check the ‘Update Notification 
Sent Date’ to advance the ‘Last 
Date’ field after the EFT 
processes.  This is used to 
determine if an EFT notice has 
been printed. 

The Default Printer is used as a 
backup in case one of the 
printers selected in Properties is 
unavailable. 
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The Interval and Increment is set 
to establish how often 
Messenger will poll for unprinted 
notices. You can also specify a 
Start Time and/or a Delay based 
on the date.  

In the example, Messenger will 
poll every 24 hours at 2:00AM for 
any EFTs that generated after 
the ‘Last Date’ and ‘Last Time’ 

displayed in Messenger.  The ‘Last Date’ and ‘Last Time’ will be updated in Messenger after the notices 
have been processed. 

The Ply Configuration and Vendor preferences use the same rules as the other form types. Refer to the 
chapter that covers Properties for further instructions. 

Messenger Client can be used to manually process the EFT notices manually by Batch number. 

To run as a replacement to the automatic processing check the ‘Update Date/time of Last Transmission’ 
box.  This will update the Last Date and Last Time fields in System Configuration. 

Checking ‘Ignore Last Process 
Date’ will allow any previously 
printed notices to be reprinted. 

The ply number can also be 
specified.  Leaving the field 
blank will process all plies 
defined on the EFT-AP tab of 
Properties. 
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PRODUCING DYNAMICS GP EFT‐DD (DIRECT DEPOSIT) 

Messenger EFT-DD is enabled under the EFT-AP/DD tab of System Configuration. 
A default printer should be selected.   A network printer is best.  Do not choose ‘Liaison Messenger 
PDF’ or any other virtual print 
driver. 

The Interval and Increment fields 
along with Start Time are used 
for scheduling Messenger to 
automatically poll for new DD 
ACH files.  The Client can also 
be used to select the ACH batch 
when ready. 

Employee information is read 
from the Employee card in 
Dynamics GP. The emails 
address pulls from the internet 
information window (italics i to 
right of address ID) The 
Password field is also read from 
this window.  Emailed PDFs of 
DD advice will require this password in order to 
open the attachment.  If no password exists the 
PDF will open without a prompt. 

 
 

 

 

 

 

 

 

 

 



LIAISON MESSENGER® END USER GUIDE 

15 

 

 

Under File | Properties | Employees tab the employees are imported using the Add button. 
This can also be accessed from Client – File | Set Recipient Preferences.   
 
NOTE: Each time a new employee is added to GP that is setup for direct deposit or a new email 
address is entered for an existing employee the Add button will need to be clicked to refresh the list. 
The buttons on the left filter the list for the purpose of determining which employees do not have 
‘Emailed’ set as the preference but 
have an email address. 

Each employee record has its own 
preference screen.  The EFT-DD 
tab contains the Direct Deposit 
preference selection list.  An 
employee can have a preference 
of Emailed or Suppress.  Blank 
selections will be treated as 
printed.  (see ply routing for more 
details) 

Under the EFT-DD tab of 
Properties the plies are configured.  
Each ply consists of various 
components which are unique to 
that ply. In the example below there is an employee copy routing to the employee’s preference and an 
archived copy creating a PDF file in the path specified. 

Double click the ply to 
open the configuration 
window.  Under the 
Routing tab the employee 
copy would have a 
routing of ‘Send Copy to 
Employee’.  This will 
send via email if the 
employee preference is 
set to ‘Emailed’.  If the 
preference is set to 
‘Suppress’ that 
employee’s notice will not 
be sent.  A blank 
employee preference will 
be treated as Printed and 
route to the Default 
printer specified on the 
EFT-AP/DD tab of 
System Configuration.   

 If no printed copy is desired for 
employees without emails a filter can be 
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placed under the Filters tab to ignore these printed copies and only send the emailed copies.  Syntax:  
LMDDFT.DDPREF=4 

The Subject line and body text 
for the employee email are 
entered under the Email Text 
tab. 
The DD advice number is 
automatically appended to the 
end of the subject line.  To 
suppress this number check the 
box on the bottom right. 

An archive copy is created by 
selection ‘Archive Copy to Disk’ 
for the routing method.  The 
path where the archived PDF 
file is to be stored is selected by 
clicking the yellow lookup icon 
to the right of the Target field.   
A UNC path can also be used 
by typing the path directly in the 
Target line. 

To add a new blank ply click the 
Add button.  To copy an existing 
ply single click the ply to copy 
then click the Clone button.  A 
new ply will be created with the 
same configuration as the one 
cloned. 
To remove a ply single click the 
ply then click the Delete button. 
The Preview and Test Print 
buttons are used to check the 
layout.  In the TWO test 
company all data will appear.  In all other companies data specific to the employee is suppressed for 
security purposes. 
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The DD advice template 
can modified by clicking 
the Modify Layout button.   
Refer to the section on 
the report designer in the 
main configuration guide. 

 

 

 

 

 

 

The Messenger Client is used to submit the job to the queue on Messenger Server to process the DD 
advice notices. 
 
The yellow lookup icons are used to 
select from the number listing.  The 
ACH index number is used to select 
the batch but the check build date is 
displayed to make the search 
easier. Clicking the column 
headings will sort by the column 
clicked. 

Check the ‘Ignore Last Process 
Date’ box to reprint older batches 
that have already been sent. 
The Ply No. selection can be used 

to only process the ply selected.  For example: to only 
resend the archive copy without resending the 
employee copy. 

Once all parameters have seen selected click the 
‘Process’ button to submit the job to the Messenger 
Server queue.   A confirmation window will appear 
indicating the job has been sent to the queue. 
The Messenger Server must be open and on the Green 
status light in order for the job to process. 
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DYNAMICS SL 

PRINTING DYNAMICS SL DOCUMENTS 

If the Unattended Processing feature is not used, forms can be processed from Messenger Client.  By 
default, Messenger Client is found on the Start Program menu in Windows under the Liaison Software 
folder.   

Optionally, you can add the respective Messenger Client Screens to the menu system under the 
respective module in Solomon IV.  

Please see the Chapter titled Call Messenger from MBS Solomon IV in the user guide or refer to your 
Solomon IV documentation for instructions on adding third party programs. 

AR INVOICES AND CREDIT MEMOS 

From the Messenger Client, select 
Print AR Invoices/Credit Memos from 
the File menu. Select the applicable 
fields and choose Process when 
ready. 

SHIPPER DOCUMENTS AND INVOICES 

From the Messenger Client, select 
Print SO Invoices/Shippers from the 

File menu. Select the applicable fields and 
choose Process when ready. 

ORDER CONFIRMATION/QUOTATIONS 

From Messenger Client select Print Sales 
Orders from the File menu. Chose the 
appropriate values and select Process.  

PURCHASE ORDERS 

From Messenger Client, choose Print 
Purchase Orders from the File menu. 

When everything has printed and looks OK, chose the appropriate values and select Process. This 
Procedure will also Post the Purchase Orders when you print them if you have the Update to the Next 
Function ID checked.  
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BILL OF LADINGS, PACKING SLIPS, SHIPPING DOCUMENTS 

From Messenger Client, choose Print Shipping Documents from the File menu. Chose the appropriate 
values and select Process.  

MAS 90/200 

PRINTING MAS 90/200 DOCUMENTS 

When you decide to 
run Messenger live, 
make sure you have 
checked Update 
<FormType> Status 
Code in System 
Configuration or 
from the respective 
Messenger Client 
window. This is the 
only way Messenger 
can update any 
Status Codes and/or 
increment the Times 
Printed fields. 

AR INVOICES AND 
CREDIT MEMOS 

From the Messenger 
Client, select Print AR Invoices/Credit Memos from the File menu. Select the applicable fields and 
choose Process when ready. 

Returns or Credit Memos will be printed within an Invoice run; however, the form will say Credit Memo 
instead of Invoice with <Credit Memo> printed across the top. This eliminates the multiple step process 
you need to print Credit memos should you require pre-printed Credit Memo forms.  

SALES ORDER INVOICES 

From the Messenger Client, select Print SO Invoices/Shippers from the File menu. Select the applicable 
fields and choose Process when ready. 

SALES ORDERS 

From Messenger Client select Print Sales Orders from the File menu. Chose the appropriate values and 
select Process.  

PURCHASE ORDERS 
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From Messenger Client, choose Print Purchase Orders from the File menu. . Chose the appropriate 
values and select Process.  

REPRINTING MAS 90/200 FORMS 

If a problem has arisen with 
the latest print job you can 
rerun the print job(s). Simply 
reselect the criteria and 
check the Include 
Previously Printed Orders 
checkbox and then choose 
Process.  
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DESKTOP FAXING, E‐MAILING, AND LOCAL PRINTING 

DESKTOP PRINTING, FAXING, AND E‐MAILING OF RECREATES 

From the Client screen, you have 
the option to E-Mail, Fax, Local 
Viewer (preview) Local Print, or 
Process.  

Of course your Messenger 
Server must be setup to fax and 
e-mail since it is that machine 
that processes the forms.   

On Prints and Previews, the local 
machine produces the form. 

Also, keep in mind that when a 
recreate is issued, the Form 
Template assigned to Ply 
number 1 of that form type is 
used unless you specify 
otherwise on this form. 

When faxing or e-mailing, 
the remittance Fax/E-mail 
Address is used.  You 
can; however, overwrite 
this before submitting. 

Faxing has the option of 
including a Cover Sheet 
with which you can add 
text or a message.  

This cover sheet must be 
identified and setup first 
on Messenger under the 
Faxing tab Server in 
System Configuration. 
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RETRIEVING ARCHIVED FORMS 

FROM MESSENGER CLIENT 

To access any previously archived form(s), choose the new Archive Manager from the File menu of 
Messenger Client.  This utility will show all archived forms as specified in Properties for each form.   

There is a tab for each form. 
The Archive Manager reads 
the directory location from 
the Properties that were 
entered for that form.  

When launched, the Archive 
Manager displays all the 
files for the respective form 
in a scrolling list box.  When 
a batch is selected (by 
double clicking), the 
respective file is displayed 
using the designated 
reader. In most cases this is 
the free Adobe Acrobat 
reader. 

FROM ARCHIVE MANAGER 

To access any previously 
archived form(s), choose the 
Archive Manager from the File 
menu of Messenger Client.  This 
utility will show all archived 
forms as specified in Properties 
for each form.   

There is a tab for each form. 
The Archive Manager reads the 
directory location from the 
Properties that were entered for 
that form. 

When launched, the Archive 
Manager displays all the files for 
the respective form in a scrolling 
list box.  When a batch is 

selected (by double clicking), the respective file is displayed using the designated reader. In most cases 
this is the free Adobe Acrobat reader. 
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INTEGRATING LIAISON MESSENGER TO MAIN SCREENS 

SAGE PFW AND BATCHMASTER 

CUSTOMIZATION WORKBENCH 

Adding the Messenger Client to the PFW menu system can easily be accomplished through the PFW 
Customization Workbench (CWB) available from Sage Software, Inc. This instruction guide is not 
intended to replace the documentation for the CWB that was provided by Sage.  Liaison Software 
Corporation does not supply the CWB. This is a purchased module and follows all of Sage Software, Inc 
licensing guidelines. To add menu items, simply follow the steps outlined below: 

You must be logged in as a user with the Developer profile.  

For each of the Modules you wish to add a Messenger menu option, here are the required 
parameters you need to call the applicable form along with the suggested Menu Caption. 

On the Menu Item Properties, choose the Display tab and set the Caption, and Service Type fields 
as described below under the Recommend Settings section.. 

The Queue tab does not contain any options related to Messenger. Accept the defaults. 

Then select the Navigation and Access tab and enter the Method and Program for the each of 
respective form types you wish to access through PFW. 

Once completed, you will have to add Access Rights for each of these options under the applicable 
User Groups. This can be accomplished under Admin user ID. 

RECOMMEND CWB PARAMETER SETTINGS: 

Caption: Print Messenger Invoices/Credit Memos 
Application: Accounts Receivable 
Service Type: Document Print and Post 
Method: Run External Program 
Program: x:\PLATINUM\LIAMCLI.EXE “ARINVOICE” 

 

Caption: Print Messenger Invoices 
Application: Sales Order 
Service Type: Document Print and Post 
Method: Run External Program 
Program x:\PLATINUM\LIAMCLI.EXE “SOINVOICE” 

 

Caption: Print and Post Messenger Sales Orders 
Application: Sales Order 
Service Type: Document Print and Post 
Method: Run External Program 
Program x:\PLATINUM\LIAMCLI.EXE "SALESORDER" 
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Caption: Print and Post Messenger Purchase Orders 
Application: Purchase Order 
Service Type: Document Print and Post 
Method: Run External Program 
Program x:\PLATINUM\LIAMCLI.EXE "PURCHASEORDER" 

 

Caption: Print Messenger Statements 
Application: Accounts Receivable 
Service Type: Report 
Method: Run External Program 
Program x:\PLATINUM\LIAMCLI.EXE "STATEMENT" 
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CWB PARAMETER SETTINGS SCREENSHOTS 

   

SCREEN SHOTS: #1 – DISPLAY TAB  #2 – QUEUE TAB 

  

#3 – NAVIGATION AND ACCESS TAB A  #4 ‐ NAVIGATION AND ACCESS TAB B 
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DYNAMICS  GP 

BATCHFILES, SHORTCUTS AND PALLETTES 

By simply calling the Liamcli.exe 
executable and passing 
additional arguments (or 
parameters) you can integrate 
Messenger into other programs 
or call certain feature directly 
from a shortcut in Windows. 

Please not that you can NOT call 
a file with Parameters in the GP 
Dynamics Shortcut capabilities. 

In order to accomplish this, create 
a good ole fashioned batch file in 
Windows Notepad like this: 

PRINTPO_TWO.BAT 

Save it in the X:\messenger 
folder. 

SYNTAX: <X:`\messenger\Liamcli.Exe <CommandID> <CompanyID> 

Using the above syntax, create a line like this and save: 

<X:>\messenger\Liamcli.Exe PURCHASEORDER TWO 

The above example would launch the Print Purchase Order window from Messenger Client directly from 
within Dynamics GP. 

The first argument is the Command ID  the second argument is the Company ID. Both are uppercase 
only because they are case sensitive. 

The Company ID identifies the 
Company dataset (i.e. The 
World Online) is actually TWO. 

For example, to call the Print 
Purchase Order Documents 
dialog box from the World 
Online, Inc would look like this: 

X:\messenger\Liamcli.Exe 
PURCHASEORDER TWO 

Below are the available commands for Liamcli.Exe. 
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Command ID:    Action 
ARINVOICE    IVC Invoice Print Documents Dialog 
SOINVOICE    SOP Invoice Print Documents Dialog 
SALESORDER    SOP Sales Order Print Documents Dialog 
PURCHASEORDER  POP Purchase Order Print Documents Dialog 
SHIPDOCS    SOP Shipping Documents Print Documents Dialog 
EBANK      EFT‐AP Vendor Remittance Print Documents Dialog 
DIRDEP    EFT‐DD Direct Deposit Print Documents Dialog 
PROPDFT    Territory, Salesperson, Location Routing Preferences 
PROPCMS    Customer Form Routing Preferences 
PROPVMS    Vendor Purchase Order Routing Preferences 
PROPCVD    All Recipient Category Routing Preferences  
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USING MODIFIER OR VBA 

Adding Messenger Client capabilities to other programs is easily accomplished with command line 
options. From Print Document windows to Recipient Preferences settings, you have complete control of 
Messenger Client without source code. 

If  you wish to add a Quick Print button to the Document entry screen that will place a Print Request for 
that order into the Messenger Queue, using Modifier or Dexterity, here is a sample VBA code  

Dim sCmd 
Dim sDoc 
        sDoc = DocumentNo 
        Save = 1 
        sCmd = "\\DSIMSSQL\Messnger\LIAMQUE.EXE SAND \\DSIMSSQL\Messnger SOP! 2 " & sDoc 
        MsgBox sCmd 
Shell (sCmd) 
   

 For SOP Docs it would be:  

 X:\MESSENGER\LIAMQUE.EXE TWO X:\MESSENGER SOP! 2 <DOC NUMBER>  

            1                                    2            3               4     5          6  

1. Path to Queue Requester  
2. Company ID  
3. Path where Messenger is installed  
4. GP document type (exclamation point tells it to ignore if document has already been printed)  
5. SOP TYPE (2=Order, 3=Invoice) Can be placed back to back i.e. 23 would print either Order or Invoice  
6. SOP Number  

You could also add # after the doctype to not update TIMESPRT as the example below illustrates: 

C:\MsgrGPtest/liamque.exe TWO C:\MsgrGPtest SOP# 2 ORDST2286   

 For Purchase orders, the syntax would be:  

 X:\MESSENGER\LIAMQUE.EXE TWO X:\MESSENGER POP! 1234 <DOC NUMBER>  

            1                                    2            3              4       5              6  

 Path to Queue Requester  

1. Company ID  
2. Path where Messenger is installed  
3. GP document type (exclamation point tells it to ignore if document has already been printed)  
4. POP Status (i.e. Open, Released, Closed etc.) Can be placed back to back i.e. 1234 would print all but 

Cancelled POs 
5. POP Doc Number  
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DYNAMICS SL 

DYNAMICS SL ORDER MANAGEMENT 

Liaison Messenger interfaces 
with Solomon IV’s Order 
Management module by 
inserting equivalent Steps in 
the SOSteps table, which is 
defined for each Order Type.  

If you plan on using 
Messenger to print, fax, e-
mail, archive, or Exchange 
Data of Order Management 
Forms (Shippers/non-
Shippers), you will need to 
update the Steps of each 

Order Type that you want 
processed. This is accomplished 
by select the Order Types screen 
from the Order Management 
module. 

If you only will be processing 
Purchase Order and Statements 
or miscellaneous Invoices and 
Returns through Messenger, then 
this configuration is not required. 

During the process of Enabling 
Company Databases when 
Messenger was being installed, 

you had an option to Load or Remove Messenger Steps.  

You should have checked Load Messenger Steps in Solomon IV, which was the default. 

By doing this, Messenger inserted directly after every Solomon IV form printing operation the equivalent 
Messenger form processing operation. By default, all of the auto-inserted forms processing steps are in 
a Bypass status. This way Solomon IV will ignore them until you are ready to activate the step. 

The descriptions of all Messenger steps begin with “Use Messenger <Form Type>“. Additionally we add 
1 number to the Sequence number of the Solomon IV form printing operation we plan on replacing or 
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enhancing and finally, we’ve created our own unique Next Function ID that one can only view when the 
initialize mode is enabled through Solomon IV. 

To enable a Messenger step: 

Double click on the respective Messenger Step. Change the Status field to Required and keep the 
Invoke Automatically option unchecked. 

When a Messenger step is set to Required, Solomon will increment any preceding step of that order 
type to Messenger’s function ID. Solomon IV will ignore these steps. Messenger will evaluate any Pre-
shipper and Shipper type document that are set to a Messenger Function ID process.  

Once selected by Messenger, the routing that 
is established for the respective order and 
function in the Properties window on the 
Messenger Server is then routed accordingly.  

After processing, Messenger will update the 
Function ID to the Next enabled step in the 
Order Type process as established in 
Solomon IV. 

In this manner you have complete control over 
your order process. We highly recommend 
enabling the Unattended Processing feature of 
Messenger for Shipper and Non-Shipper type 
orders.  


